CVE-2026-67590
High
Description
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid ProtonJ2: through 1.1.0. Users are recommended to upgrade to version 1.2.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Qpid
PublishedAug 5, 2026
First seenAug 5, 2026
Weakness typeCWE-674CWE-674
How to fix
Update
- apache qpid_protonj21.2.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache qpid_protonj2 | v < 1.2.0 | 1.2.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.