CVE-2026-68536

Critical

Description

Server-Side Request Forgery / Local File Inclusion in Apache MyFace Core. Older unsupported versions may also be affected.  Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache MyFaces
PublishedSep 16, 2026
First seenSep 16, 2026

How to fix

Update
  • Apache Software Foundation Apache MyFaces2.3-next-M9, 2.3.12, 3.0.4, 4.0.4, 4.1.4 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache MyFaces2.2.0-beta ≤ v ≤ 2.2.15, 2.3.0, 2.3-next-M1 ≤ v < 2.3-next-M9, 2.3.1 ≤ v < 2.3.12, 3.0.0 ≤ v < 3.0.4, 4.0.0 ≤ v < 4.0.4, 4.1.0 ≤ v < 4.1.42.3-next-M9, 2.3.12, 3.0.4, 4.0.4, 4.1.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.