CVE-2026-68570
Description
Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access data they are not authorized to read, resulting in unauthorized disclosure of information. This issue affects Apache Doris: from 2.0.0 through 2.1.*, from 3.0.0 through 3.0.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4. Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.
How to fix
- Apache Software Foundation Apache Doris4.0.8, 4.1.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Doris | 2.0.0 ≤ v ≤ 2.1.*, 3.0.0 ≤ v ≤ 3.0.*, 4.0.0 ≤ v < 4.0.8, 4.1.0 ≤ v < 4.1.4 | 4.0.8, 4.1.4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.