CVE-2026-68571

High

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. Special parameter in JDBC URL can lead to code injection.  Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Kylin
PublishedOct 16, 2026
First seenOct 16, 2026

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Kylin4.0.0 ≤ v ≤ 5.0.4—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.