CVE-2026-69149

Medium

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.7, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of fallback raw-content elements (<iframe>, <noembed>, <noframes>, and <noscript>). This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.7.

SeverityMedium
CVSS6.1
Exploit probability—
ProductAngular
PublishedAug 3, 2026
First seenAug 3, 2026

How to fix

Update
  • angular angular20.3.27, 21.2.19, 22.0.7 or later
  • @angular/platform-server22.0.7, 21.2.19, 20.3.27 or later

Affected products

ProductAffected versionsFixed in
angular angularv ≤ 19.2.25, 20.0.0 ≤ v < 20.3.27, 21.0.0 ≤ v < 21.2.19, 22.0.0 ≤ v < 22.0.720.3.27, 21.2.19, 22.0.7
@angular/platform-servernpm22.0.0-next.0 ≤ v < 22.0.7, 21.0.0-next.0 ≤ v < 21.2.19, 20.0.0-next.0 ≤ v < 20.3.27, v ≤ 19.2.2522.0.7, 21.2.19, 20.3.27

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.