CVE-2026-69220

High

Description

The RabbitMQ Java client library allows Java and JVM-based applications to connect to and interact with RabbitMQ nodes. Prior to 5.33.1, src/main/java/com/rabbitmq/client/impl/ValueReader.java permits ValueReader.readTable and ValueReader.readArray to call ValueReader.readFieldValue recursively for AMQP table type F and AMQP array type A values without a nesting-depth limit. A malicious AMQP server or network intermediary can send approximately 580 nested table levels in the pre-authentication connection.start frame, fitting within the default 131072-byte frame maximum, to trigger StackOverflowError. The error terminates the client input processing thread and causes denial of service. This issue is fixed in version 5.33.1.

SeverityHigh
CVSS8.7
Exploit probability—
ProductCom.rabbitmq:amqp-client
PublishedAug 18, 2026
First seenAug 18, 2026
Weakness typeCWE-674CWE-674

How to fix

Update
  • com.rabbitmq:amqp-client5.33.1 or later

Affected products

ProductAffected versionsFixed in
com.rabbitmq:amqp-clientMavenv < 5.33.15.33.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.