CVE-2026-6986

Low

Description

A security vulnerability has been detected in Cesanta Mongoose up to 7.20. This issue affects the function mg_aes_gcm_decrypt of the file /src/tls_aes128.c of the component GCM Authentication Tag Handler. Such manipulation leads to improper verification of cryptographic signature. The attack may be performed from remote. A high complexity level is associated with this attack. The exploitability is assessed as difficult. The exploit has been disclosed publicly and may be used. Upgrading to version 7.21 is capable of addressing this issue. It is advisable to upgrade the affected component. VulDB has contacted the vendor early and they confirmed quickly, that this issue got fixed already.

SeverityLow
CVSS3.7
Exploit probability—
ProductCesanta Mongoose
PublishedApr 25, 2026
First seenApr 25, 2026

How to fix

Update
  • cesanta mongoose7.21 or later

Affected products

ProductAffected versionsFixed in
cesanta mongoose7.0 ≤ v < 7.217.21

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.