CVE-2026-71537

Medium

Description

Paymenter is a free and open-source webshop solution for management of hosting services. Prior to 1.5.7, app/Livewire/Services/Upgrade.php::doUpgrade() relies on Service::upgradable to check for a pending service upgrade and later executes $credit->increment('amount', abs($price)) without DB::transaction or lockForUpdate() spanning those operations. An authenticated customer with an active downgradable service can submit concurrent downgrade requests that each observe no pending upgrade, create separate upgrade records, and increment the same account credit balance, producing multiple spendable refunds for one downgrade. This issue is fixed in version 1.5.7.

SeverityMedium
CVSS6.5
Exploit probability—
ProductPaymenter/paymenter
PublishedSep 18, 2026
First seenSep 18, 2026

How to fix

Update
  • paymenter/paymenter1.5.7 or later

Affected products

ProductAffected versionsFixed in
paymenter/paymenterPackagistv < 1.5.71.5.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.