CVE-2026-71558

Critical

Description

Heap type confusion vulnerability in Apache Fory C++ deserialization. This issue affects Apache Fory C++ versions from 0.14.0 before 1.5.0. A crafted input payload can bypass type compatibility checks during polymorphic smart-pointer deserialization, causing an object of an incompatible type to be treated as the declared base type. This may result in undefined behavior and potentially lead to denial of service or arbitrary code execution. Users are recommended to upgrade to Apache Fory 1.5.0, which fixes this issue. Applications not using Apache Fory C++ polymorphic smart-pointer deserialization are not affected.

SeverityCritical
CVSS9.8
Exploit probability—
ProductApache Fory
PublishedAug 7, 2026
First seenAug 7, 2026

How to fix

Update
  • apache fory1.5.0 or later

Affected products

ProductAffected versionsFixed in
apache fory0.14.0 ≤ v < 1.5.01.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.