CVE-2026-71559

High

Description

Deserialization of Untrusted Data vulnerability in the Go implementation of Apache Fory allows an attacker to cause a denial of service by supplying crafted data containing malformed type metadata, which triggers an uncaught panic. This issue affects Apache Fory: from 0.16.0 before 1.5.0.  Users of other language implementations are not affected. Users are recommended to upgrade to version 1.5.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Fory
PublishedAug 7, 2026
First seenAug 7, 2026

How to fix

Update
  • apache fory1.5.0 or later

Affected products

ProductAffected versionsFixed in
apache fory0.16.0 ≤ v < 1.5.01.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.