CVE-2026-73070

Medium

Description

Vim is an open source, command line text editor. Prior to 9.2.0842, the socket server backend in src/socketserver.c accepts unbounded client connections in socketserver_accept(), causing descriptors to overflow fd_set structures in src/channel.c and fixed-size struct pollfd arrays in src/os_unix.c, which allows a local process that can connect to the server socket to corrupt stack memory or terminate the Vim server. This issue is fixed in version 9.2.0842.

SeverityMedium
CVSS5.5
Exploit probability—
ProductVim
PublishedAug 11, 2026
First seenAug 11, 2026
Weakness typeCWE-121CWE-121

How to fix

Update
  • vim vim9.2.0842 or later

Affected products

ProductAffected versionsFixed in
vim vimv < 9.2.0842, 9.2.0512 ≤ v < 9.2.08429.2.0842

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-73070 · Vim · Dark Radar