CVE-2026-73180
Description
Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
How to fix
- apache tomcat9.0.121, 10.1.58, 11.0.25 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 7.0.43 ≤ v ≤ 7.0.109, 8.5.0 ≤ v < 9.0.121, 10.1.0 ≤ v < 10.1.58, 11.0.0 ≤ v < 11.0.25 | 9.0.121, 10.1.58, 11.0.25 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.