CVE-2026-73255

Medium

Description

Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.

SeverityMedium
CVSS6.5
Exploit probability—
ProductCesanta Mongoose
PublishedAug 20, 2026
First seenAug 20, 2026

How to fix

Update
  • cesanta mongoose7.22 or later

Affected products

ProductAffected versionsFixed in
cesanta mongoosev < 7.227.22

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.