CVE-2026-73557

Medium

Description

vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.

SeverityMedium
CVSS5.3
Exploit probability—
ProductVllm
PublishedAug 13, 2026
First seenAug 13, 2026

How to fix

Update
  • vllm vllm0.26.0 or later
  • vllm0.26.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.21.0 ≤ v < 0.26.00.26.0
vllmPyPI0.21.0 ≤ v < 0.26.00.26.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.