CVE-2026-73558

Medium

Description

vLLM is an inference and serving engine for large language models. Prior to 0.27.0, an integer overflow in blockIdx.x * 2 * d in activation_kernels.cu can cause act_and_mul_kernel to consume another batched user's input, allowing a request processed in the same inference batch to receive a partial or complete copy of another user's inference result. This issue is fixed in version 0.27.0.

SeverityMedium
CVSS5.3
Exploit probability—
ProductVllm
PublishedAug 13, 2026
First seenAug 13, 2026

How to fix

Update
  • vllm vllm0.27.0 or later
  • vllm0.27.0 or later

Affected products

ProductAffected versionsFixed in
vllm vllmv < 0.27.00.27.0
vllmPyPIv < 0.27.00.27.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-73558 · Vllm · Dark Radar