CVE-2026-73581

Medium

Description

Improper Check for Certificate Revocation vulnerability in Apache Tomcat. Both the OpenSSL and OpenSSL-FFM TLS implementations ignore CRLs when certificate uses a keystore. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0-M1 through 9.0.121. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.59, 9.0.122, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Tomcat
PublishedSep 23, 2026
First seenSep 23, 2026
Weakness typeCWE-299CWE-299

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Tomcat11.0.0-M1 ≤ v ≤ 11.0.25, 10.1.0-M1 ≤ v ≤ 10.1.59, 9.0.0.M1 ≤ v ≤ 9.0.121, 8.5.0 ≤ v ≤ 8.5.100—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.