CVE-2026-73635

High

Description

Allocation of resources without limits or throttling vulnerability in Apache Struts. When no fixed locale is configured, the locale used for localized-text lookups is taken from the incoming request, allowing an unauthenticated remote client to cause the framework's internal localized-text caches to grow without bound and exhaust the Java heap, denying service to other users. Applications that configure a fixed locale are not affected. This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Struts
PublishedAug 15, 2026
First seenAug 15, 2026

How to fix

Update
  • apache struts6.11.0, 7.3.0 or later

Affected products

ProductAffected versionsFixed in
apache struts2.0.0 ≤ v ≤ 2.3.37, 2.5.0 ≤ v ≤ 2.5.33, 6.0.0 ≤ v < 6.11.0, 7.0.0 ≤ v < 7.3.06.11.0, 7.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.