CVE-2026-74848
High
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling') vulnerability in Apache APISIX. An attacker could make other clients receive attacker-chosen or other users' responses on serverless-plugin routes. This issue affects Apache APISIX: from 2.12.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Apisix
PublishedAug 27, 2026
First seenAug 27, 2026
Weakness typeCWE-444CWE-444
How to fix
Update
- apache apisix3.18.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache apisix | 2.12.0 ≤ v < 3.18.0 | 3.18.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.