CVE-2026-75020

High

Description

Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX. A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach. This issue affects Apache APISIX: from 2.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Apisix
PublishedAug 27, 2026
First seenAug 27, 2026
Weakness typeCWE-90CWE-90

How to fix

Update
  • apache apisix3.18.0 or later

Affected products

ProductAffected versionsFixed in
apache apisix2.11.0 ≤ v < 3.18.03.18.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.