CVE-2026-7541
Description
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause service disruption by sending crafted requests with deeply nested JSON payloads to an unauthenticated API endpoint. The endpoint parsed user-controlled JSON request bodies without size or depth limits, causing excessive CPU and memory consumption. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18. This vulnerability was reported via the GitHub Bug Bounty program.
How to fix
- github enterprise_server3.16.18, 3.17.15, 3.18.9, 3.19.6, 3.20.2 or later
- docs.github.com/en/[email protected]/admin/release-notes#3.16.18
- docs.github.com/en/[email protected]/admin/release-notes#3.17.15
- docs.github.com/en/[email protected]/admin/release-notes#3.18.9
- docs.github.com/en/[email protected]/admin/release-notes#3.19.6
- docs.github.com/en/[email protected]/admin/release-notes#3.20.2
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | v < 3.16.18, 3.17.0 ≤ v < 3.17.15, 3.18.0 ≤ v < 3.18.9, 3.19.0 ≤ v < 3.19.6, 3.20.0 ≤ v < 3.20.2 | 3.16.18, 3.17.15, 3.18.9, 3.19.6, 3.20.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.