CVE-2026-75857
Description
CodeWhale versions >= 0.8.41 and < 0.8.64 contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in 0.8.64.
How to fix
- codewhale0.8.64 or later
- deepseek-tui0.8.41 or later
- codewhale-tui0.8.64 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| codewhalenpm | 0.8.41 ≤ v < 0.8.64 | 0.8.64 |
| deepseek-tuicrates.io | 0.3.10 ≤ v ≤ 0.8.41, 0.3.10 ≤ v < 0.8.41 | 0.8.41 |
| codewhale-tuicrates.io | 0.8.41 ≤ v < 0.8.64 | 0.8.64 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.