CVE-2026-75858

High

Description

CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats as 'never prompt,' causing arbitrary model-supplied Python code to run in a python3 interpreter without consulting the user's configured --approval-policy and without any approval prompt or audit step. An attacker can induce the agent to execute arbitrary code via prompt injection in untrusted content the agent reads (a web page, fetched URL, repository file, or MCP tool result); the companion rlm_open tool can stage such content. Code runs on the user's machine at the user's privilege level. Fixed in 0.8.64.

SeverityHigh
CVSS7.8
Exploit probability—
ProductCodewhale-tui
PublishedAug 18, 2026
First seenAug 18, 2026

How to fix

Update
  • codewhale-tui0.8.64 or later
  • deepseek-tui0.8.41 or later
  • codewhale0.8.64 or later

Affected products

ProductAffected versionsFixed in
codewhale-tuicrates.io0.8.41 ≤ v < 0.8.640.8.64
deepseek-tuicrates.io0.8.33 ≤ v ≤ 0.8.41, 0.8.33 ≤ v < 0.8.410.8.41
codewhalenpm0.8.41 ≤ v < 0.8.640.8.64

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-75858 · Codewhale-tui · Dark Radar