CVE-2026-75880
Description
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes this issue.
How to fix
- apache artemis2.44.0, 2.57.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache artemis | 1.0.0 ≤ v < 2.44.0, 2.50.0 ≤ v < 2.57.0 | 2.44.0, 2.57.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.