CVE-2026-75913
Description
CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in 0.8.64 by adding rev validation.
How to fix
- codewhale-tui0.8.64 or later
- deepseek-tui0.8.41 or later
- codewhale0.8.64 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| codewhale-tuicrates.io | 0.8.41 ≤ v < 0.8.64 | 0.8.64 |
| deepseek-tuicrates.io | 0.3.27 ≤ v ≤ 0.8.41, 0.3.27 ≤ v < 0.8.41 | 0.8.41 |
| codewhalenpm | 0.8.41 ≤ v < 0.8.64 | 0.8.64 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.