CVE-2026-75975
Description
fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.
How to fix
- openjsf fast-uri2.4.5, 3.1.6, 4.1.3 or later
- fast-uri2.4.5, 3.1.6, 4.1.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openjsf fast-uri | 2.3.1 ≤ v < 2.4.5, 3.0.0 ≤ v < 3.1.6, 4.0.0 ≤ v < 4.1.3 | 2.4.5, 3.1.6, 4.1.3 |
| fast-urinpm | 2.3.1 ≤ v < 2.4.5, 3.0.0 ≤ v < 3.1.6, 4.0.0 ≤ v < 4.1.3 | 2.4.5, 3.1.6, 4.1.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.