CVE-2026-77078

High

Description

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.

SeverityHigh
CVSS7.5
Exploit probability—
ProductExpressjs Multer
PublishedAug 28, 2026
First seenAug 28, 2026
Weakness typeCWE-248CWE-248

How to fix

Update
  • expressjs multer2.3.0 or later
  • multer2.3.0 or later

Affected products

ProductAffected versionsFixed in
expressjs multerv < 2.3.02.3.0
multernpmv < 2.3.02.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.