CVE-2026-7736

High

Description

A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.

SeverityHigh
CVSS7.3
Exploit probability—
ProductOsrg Gobgp
PublishedMay 4, 2026
First seenMay 4, 2026

How to fix

Update
  • osrg gobgp4.4.0 or later
  • github.com/osrg/gobgp/v44.4.0 or later

Affected products

ProductAffected versionsFixed in
osrg gobgpv < 4.4.04.4.0
github.com/osrg/gobgp/v4Gov < 4.4.04.4.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.