CVE-2026-77635

Critical

Description

CakePHP is a rapid development framework for PHP. Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue() with PostgresDriver is vulnerable to SQL injection when user-controlled data is supplied to the jsonPath parameter. This issue is fixed in versions 5.1.10, 5.2.15, and 5.3.7.

SeverityCritical
CVSS9.2
Exploit probability—
ProductCakephp/cakephp
PublishedAug 24, 2026
First seenAug 24, 2026
Weakness typeCWE-89SQL injection

How to fix

Update
  • cakephp/cakephp5.3.7, 5.2.15, 5.1.10 or later
  • cakephp/database5.3.7, 5.2.15, 5.1.10 or later

Affected products

ProductAffected versionsFixed in
cakephp/cakephpPackagist5.3.0 ≤ v < 5.3.7, 5.2.0 ≤ v < 5.2.15, 5.1.0 ≤ v < 5.1.105.3.7, 5.2.15, 5.1.10
cakephp/databasePackagist5.3.0 ≤ v < 5.3.7, 5.2.0 ≤ v < 5.2.15, 5.1.0 ≤ v < 5.1.105.3.7, 5.2.15, 5.1.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.