CVE-2026-78243

Low

Description

Apache YuniKorn 1.8.0 and later, if configured with the LDAP group resolver, crashes due to an out of bounds read processing group membership entries.If the LDAP server returns a group membership entry, memberOf attribute, for a user specified in the pod the server crashes if a membership record does not start with "CN=". This only affects install that have the non default LDAP group provider configured.  Users are recommended to upgrade to version 1.10.0, which fixes this issue.

SeverityLow
CVSS2.1
Exploit probability—
ProductApache YuniKorn
PublishedOct 7, 2026
First seenOct 7, 2026
Weakness typeCWE-248CWE-248

How to fix

Update
  • Apache Software Foundation Apache YuniKorn1.10.0 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache YuniKorn1.8.0 ≤ v < 1.10.01.10.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.