CVE-2026-78437

High

Description

Incomplete cleanup vulnerability in Apache Tomcat allows a malformed request to potentially (depends on timing) cause one request from another user to fail. This issue affects Apache Tomcat: from 11.0.19 through 11.0.25, from 10.1.53 through 10.1.59, from 9.0.116 through 9.0.121. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Tomcat
PublishedSep 23, 2026
First seenSep 23, 2026
Weakness typeCWE-459CWE-459

How to fix

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache Tomcat11.0.19 ≤ v ≤ 11.0.25, 10.1.53 ≤ v ≤ 10.1.59, 9.0.116 ≤ v ≤ 9.0.121—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.