CVE-2026-78654
Description
A vulnerability has been found in cleverbrush framework and deep up to 4.4.0. This impacts the function deepExtend of the file libs/deep/src/deepExtend.ts. The manipulation leads to improperly controlled modification of object prototype attributes. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.1 will fix this issue. The identifier of the patch is 810398c1308c500c3b8b6af380b5a89371389327. You should upgrade the affected component.
How to fix
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| cleverbrush framework | 4.0, 4.1, 4.2, 4.3, 4.4.0 | — |
| cleverbrush deep | 4.0, 4.1, 4.2, 4.3, 4.4.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.