CVE-2026-80352
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Camel K. A YAML injection vulnerability in custom resource configuration allows an authorized CR author to inject arbitrary Kubernetes objects, potentially enabling unauthorized resource creation with the privileges of the operator. This issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2. Users are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.
How to fix
- apache camel2.9.3, 2.10.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache camel | 2.0.0 ≤ v < 2.9.3, 2.10.0 ≤ v < 2.10.2 | 2.9.3, 2.10.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.