CVE-2026-80354

High

Description

Authorization bypass through User-Controlled key vulnerability in Apache Camel K. An authorization vulnerability in custom resource resolution allows a tenant to reference secrets by name in the operator namespace, potentially exposing secrets belonging to other tenants or operator components. This issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2. Users are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.

SeverityHigh
CVSS8.1
Exploit probability—
ProductApache Camel
PublishedSep 10, 2026
First seenSep 10, 2026

How to fix

Update
  • apache camel2.9.3, 2.10.2 or later

Affected products

ProductAffected versionsFixed in
apache camel2.0.0 ≤ v < 2.9.3, 2.10.0 ≤ v < 2.10.22.9.3, 2.10.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.