CVE-2026-8088

Low

Description

A weakness has been identified in OSGeo gdal up to 3.13.0dev-4. The affected element is the function GDfieldinfo of the file frmts/hdf4/hdf-eos/GDapi.c. Executing a manipulation can lead to out-of-bounds read. The attack needs to be launched locally. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.13.0RC1 is sufficient to fix this issue. This patch is called a791f70f8eaec540974ec989ca6fb00266b7646c. The affected component should be upgraded.

SeverityLow
CVSS3.3
Exploit probability—
ProductOsgeo Gdal
PublishedMay 7, 2026
First seenMay 7, 2026

How to fix

Affected products

ProductAffected versionsFixed in
osgeo gdalv ≤ 3.12.4, 3.13.0—
gdalPyPIv < 3.13.03.13.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.