CVE-2026-81719

High

Description

openssl_encrypt before 1.4.9 executes untrusted third-party plugins with insufficient controls: the plugin signature policy defaulted to WARN, so an unsigned/unverifiable non-built-in plugin was compiled and executed in the host process at import time, before the runtime sandbox is installed. The only default gate was an incomplete, bypassable AST denylist. If a user is induced to load an attacker's plugin, this results in arbitrary code execution with the privileges of the user running openssl_encrypt. Fixed in 1.4.9 by defaulting the signature policy to ENFORCE for non-built-in plugins.

SeverityHigh
CVSS7.8
Exploit probability—
ProductJahlives Openssl Encrypt
PublishedAug 27, 2026
First seenAug 27, 2026

How to fix

Update
  • jahlives openssl_encrypt1.4.9 or later
  • openssl-encrypt1.4.9 or later

Affected products

ProductAffected versionsFixed in
jahlives openssl_encryptv < 1.4.91.4.9
openssl-encryptPyPIv < 1.4.91.4.9

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.