CVE-2026-8212

Medium

Description

A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.

SeverityMedium
CVSS5.3
Exploit probability—
ProductOsgeo Gdal
PublishedMay 9, 2026
First seenMay 9, 2026

How to fix

Affected products

ProductAffected versionsFixed in
osgeo gdalv ≤ 3.12.4, 3.13.0—
gdalPyPIv < 3.13.0RC1, No range specified3.13.0RC1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.