CVE-2026-82333

High

Description

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request with two specially crafted text field names can make multer's field parser synchronously iterate a maximum-length sparse array, blocking the event loop so the process cannot handle other requests. A large numeric array index in the first field allocates a maximum-length sparse array, and a second field with a non-numeric key then triggers a full-length iteration inside the append-field dependency. All versions before 2.3.0 are affected, and this is a remotely triggerable denial of service. multer 2.3.0 adds an opt-in fieldArrayIndexLimit option that rejects oversized array indexes. Upgrade to multer 2.3.0 and set limits.fieldArrayIndexLimit to the largest array index your application needs to remediate.

SeverityHigh
CVSS7.5
Exploit probability—
ProductExpressjs Multer
PublishedAug 28, 2026
First seenAug 28, 2026

How to fix

Update
  • expressjs multer2.3.0 or later
  • multer2.3.0 or later

Affected products

ProductAffected versionsFixed in
expressjs multerv < 2.3.02.3.0
multernpmv < 2.3.02.3.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.