CVE-2026-82806

Medium

Description

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache APISIX
PublishedOct 1, 2026
First seenOct 1, 2026
Weakness typeCWE-488CWE-488

How to fix

Update
  • Apache Software Foundation Apache APISIX3.7.0 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache APISIX2.3.0 ≤ v < 3.7.03.7.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.