CVE-2026-84315

High

Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, Nginx UI does not apply RequireSecureSession to multiple authenticated mutation routes even though OTP-enabled users are expected to present a fresh X-Secure-Session-ID for sensitive actions. A stolen authenticated session can therefore create or alter automatic backups, DNS credentials and records, certificates and ACME users, Nginx control settings, and site or stream automation without completing the OTP or passkey step-up. This issue is fixed in version 2.4.1.

SeverityHigh
CVSS8.3
Exploit probability—
ProductGithub.com/0xjacky/nginx-ui
PublishedOct 12, 2026
First seenOct 12, 2026

How to fix

Update
  • github.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0 or later

Affected products

ProductAffected versionsFixed in
github.com/0xJacky/Nginx-UIGov < 1.9.10-0.20260703131214-23d1934099b01.9.10-0.20260703131214-23d1934099b0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.