CVE-2026-84360

High

Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.

SeverityHigh
CVSS8.1
Exploit probability—
ProductGithub.com/0xjacky/nginx-ui
PublishedOct 12, 2026
First seenOct 12, 2026
Weakness typeCWE-288CWE-288

How to fix

Update
  • github.com/0xJacky/Nginx-UI1.9.10-0.20260703131214-23d1934099b0 or later

Affected products

ProductAffected versionsFixed in
github.com/0xJacky/Nginx-UIGov < 1.9.10-0.20260703131214-23d1934099b01.9.10-0.20260703131214-23d1934099b0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.