CVE-2026-84361

High

Description

Composer is a dependency Manager for the PHP language. From 1.0 until 2.2.30 and 2.10.3, a malicious dependency package from a custom Composer repository or an untrusted composer.lock file could set source.type to perforce and source.url to an rsh: or jsh: P4PORT value. When the Perforce p4 client was installed and Composer installed the package from source through composer install or composer update, including --prefer-source, Composer\Util\Perforce passed the address to p4 without validation, causing p4 to run a local command with the privileges of the user or CI account. Packagist.org does not permit Perforce source metadata. This issue is fixed in versions 2.2.30 and 2.10.3.

SeverityHigh
CVSS7.7
Exploit probability—
ProductComposer/composer
PublishedSep 1, 2026
First seenSep 1, 2026

How to fix

Update
  • composer/composer2.10.3, 2.2.30 or later

Affected products

ProductAffected versionsFixed in
composer/composerPackagist2.3.0 ≤ v < 2.10.3, 1.0 ≤ v < 2.2.302.10.3, 2.2.30

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.