CVE-2026-84377

Medium

Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to versions 1.88.6 and 1.96.2, any authenticated LiteLLM proxy user could redirect an outbound provider call to a destination the user controls and cause the proxy to send its configured provider credentials to that destination. Request validation in litellm/proxy/auth/auth_utils.py, litellm/proxy/common_request_processing.py, litellm/proxy/health_endpoints/_health_endpoints.py, litellm/proxy/image_endpoints/endpoints.py, and litellm/proxy/litellm_pre_call_utils.py used incomplete checks that did not cover every sensitive parameter or inspect equivalent values across nested request fields, path values, and bracket-notation form data. Routing and credential parameters including api_base, base_url, model_list, fallbacks, and litellm_credential_name could therefore be applied without clearing the operator's stored key, exposing upstream provider credentials and other configured secrets and permitting server-side requests to internal services reachable by the proxy. This issue is fixed in versions 1.88.6 and 1.96.2.

SeverityMedium
CVSS6.5
Exploit probability—
ProductLitellm
PublishedSep 2, 2026
First seenSep 2, 2026

How to fix

Update
  • litellm1.88.6, 1.89.7, 1.90.7, 1.91.5, 1.92.2, 1.93.2, 1.94.3, 1.95.1, 1.96.2 or later

Affected products

ProductAffected versionsFixed in
litellmPyPIv < 1.88.6, 1.89.0 ≤ v < 1.89.7, 1.90.0 ≤ v < 1.90.7, 1.91.0 ≤ v < 1.91.5, 1.92.0 ≤ v < 1.92.2, 1.93.0 ≤ v < 1.93.2, 1.94.0 ≤ v < 1.94.3, 1.95.0 ≤ v < 1.95.1, 1.96.0 ≤ v < 1.96.21.88.6, 1.89.7, 1.90.7, 1.91.5, 1.92.2, 1.93.2, 1.94.3, 1.95.1, 1.96.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2026-84377 · Litellm · Dark Radar