CVE-2026-85229
Medium
Description
** UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI. This issue affects Apache SkyWalking UI : from 10.2.0 through 10.4.0. Users are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.
SeverityMedium
CVSS6.1
Exploit probability—
ProductApache SkyWalking
PublishedSep 4, 2026
First seenSep 4, 2026
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache SkyWalking | 10.2.0 ≤ v ≤ 10.4.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.