CVE-2026-85499

Critical

Description

Improper Authorization vulnerability in Apache SkyWalking BanyanDB. The Canopy includes incomplete proof-of-concept role and monitoring-proxy functionality. Under a non-default configuration with a readonly Canopy user and a reachable monitoring target, that user can send non-read requests through the monitoring proxy. This issue affects Apache SkyWalking BanyanDB: from 0.11.0 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

SeverityCritical
CVSS9.1
Exploit probability—
ProductApache SkyWalking BanyanDB
PublishedOct 12, 2026
First seenOct 12, 2026

How to fix

Update
  • Apache Software Foundation Apache SkyWalking BanyanDB0.11.1 or later

Affected products

ProductAffected versionsFixed in
Apache Software Foundation Apache SkyWalking BanyanDB0.11.0 ≤ v < 0.11.10.11.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.