CVE-2026-86243
High
Description
Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Tomcat Native
PublishedSep 23, 2026
First seenSep 23, 2026
Weakness typeCWE-126CWE-126
How to fix
Update
- apache tomcat_native1.3.9, 2.0.16 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat_native | 1.3.0 ≤ v < 1.3.9, 2.0.0 ≤ v < 2.0.16 | 1.3.9, 2.0.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.