CVE-2026-86246
Description
Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure options by default including ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF and ALLOW_NO_DHE_KEX. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fix the issue.
How to fix
- apache tomcat_native1.3.9, 2.0.16 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat_native | 1.3.0 ≤ v < 1.3.9, 2.0.0 ≤ v < 2.0.16 | 1.3.9, 2.0.16 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.