CVE-2026-86248
Critical
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from 10.1.22 through 10.1.59, from 9.0.92 through 9.0.121. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Tomcat
PublishedSep 23, 2026
First seenSep 23, 2026
Weakness typeCWE-287Improper authentication
How to fix
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Tomcat | 11.0.0-M14 ≤ v ≤ 11.0.25, 10.1.22 ≤ v ≤ 10.1.59, 9.0.92 ≤ v ≤ 9.0.121 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.