CVE-2026-87798
Description
Improper link resolution in the recursive file pull feature of the LXD CLI client in Canonical LXD versions 4.0.2 up to 6.9 (fixed in 4.0.14, 5.0.10 and 5.21.8) on Linux allows an attacker with root access inside a virtual machine to write attacker-controlled files or directory trees to arbitrary paths on the client host, with the operator's privileges. The attacker does this by using a modified lxd-agent that returns inconsistent SFTP directory listings and Lstat results.
How to fix
- Canonical LXD4.0.14, 5.0.10, 5.21.8, 6.9 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Canonical LXD | 4.0.2 ≤ v < 4.0.14, 5.0.0 ≤ v < 5.0.10, 5.21.0 ≤ v < 5.21.8, 6.0 ≤ v < 6.9 | 4.0.14, 5.0.10, 5.21.8, 6.9 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.