CVE-2026-87830
Critical
Description
In the StAX streaming WS-SecurityPolicy validator, certain relative or unsupported XPath expressions can be converted into paths that never match the actual XML element path. A remote SOAP peer may therefore send a required element without the expected signature or encryption. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
SeverityCritical
CVSS9.1
Exploit probability—
Product
Apache Wss4j
PublishedSep 30, 2026
First seenSep 30, 2026
Weakness typeCWE-917Expression language injection
How to fix
Update
- apache wss4j2.4.4, 3.0.6, 4.0.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache wss4j | v < 2.4.4, 3.0.0 ≤ v < 3.0.6, 4.0.0 ≤ v < 4.0.2 | 2.4.4, 3.0.6, 4.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.