CVE-2026-87908

High

Description

multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMultiparty
PublishedSep 11, 2026
First seenSep 11, 2026

How to fix

Update
  • multiparty multiparty4.3.1 or later

Affected products

ProductAffected versionsFixed in
multiparty multiparty2.1.0 ≤ v < 4.3.14.3.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.